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Introduction:
Microsoft Excel is a spreadsheet program designed for everyday tasks such as setting up a budget, maintaining an address list, or keeping track of a list of to-do items. 
Within Excel are a wide range of ‘functions’ which allow you to manipulate and process data to produce the outcomes you desire. Excel also allows you the user to produce a wide range of charts and graphs to support the data functions
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Chapter 1:	Range
 
In this first section, we will be looking at the following, all of which contribute to developing a range: - Cell, Row, and Column
We will then begin to develop: Range Examples, Fill a Range, Move a Range, Copy/Paste a Range, Insert Row, Column

A range in Excel is a collection of two or more cells. This chapter gives an overview of some very important range operations.
[bookmark: cell-row-column]Cell, Row, Column
Let's start by selecting a cell, row and column.
1. To select cell C3, click on the box at the intersection of column C and row 3.
[image: Select a Cell]
2. To select column C, click on the column C header.
[image: Select a Column in Excel]
3. To select row 3, click on the row 3 header.
[image: Select a Row]
[bookmark: range-examples]
Range Examples

A range is a collection of two or more cells. 
1. To select the range B2:C4, click on cell B2 and drag it to cell C4.
[image: Range in Excel]
2. To select a range of individual cells, hold down CTRL and click on each cell that you want to include in the range.
[image: A Range of Individual Cells]
[bookmark: fill-range]
Fill a Range

To fill a range, execute the following steps.
1a. Enter the value 2 into cell B2.
[image: Enter a Value]
1b. Select cell B2, click on the lower right corner of cell B2 and drag it down to cell B8.
[image: Drag it down]

Result:
[image: Drag Down Result]
This dragging technique is very important and you will use it very often in Excel. Here's another example.

2a. Enter the value 2 into cell B2 and the value 4 into cell B3.
[image: A pattern]

2b. Select cell B2 and cell B3, click on the lower right corner of this range and drag it down
[image: Pattern Dragged Down]

Excel automatically fills the range based on the pattern of the first two values. 
Here's another example.




3a. Enter the date 6/13/2016 into cell B2 and the date 6/16/2016 into cell B3.
[image: Date Pattern]

3b. Select cell B2 and cell B3, click on the lower right corner of this range and drag it down.
[image: Date Pattern Dragged Down]

Move a Range
To move a range, execute the following steps.
1. Select a range and click on the border of the range.
[image: Move a Range]

2. Drag the range to its new location.
[image: Move Result]
[bookmark: copy-paste-range]
Copy/Paste a Range

To copy and paste a range, execute the following steps.
1. Select the range, right click, and then click Copy (or press CTRL + c).
[image: Copy/Paste a Range]

2. Select the cell where you want the first cell of the range to appear, right click, and then click Paste under 'Paste Options:' (or press CTRL + v).
[image: Copy/Paste Result]
[bookmark: insert-row-column]
Insert Row, Column
To insert a row between the values 20 and 40 below, execute the following steps.
1. Select row 3.
[image: Insert a Row]

2. Right click, and then click Insert
[image: Click Insert]
Result:
[image: Inserted Row]
The rows below the new row are shifted down. 
In a similar way, you can insert a column.


Chapter 2:	Formulas and functions
In this section we are looking at how you: enter a function, edit a formula, operator precedence, copy/paste a formula and insert a function
A formula is an expression which calculates the value of a cell. Functions are predefined formulas and are already available in Excel.
For example, cell A3 below contains a formula which adds the value of cell A2 to the value of cell A1.
[image: Formula in Excel]
For example, cell A3 below contains the SUM function which calculates the sum of the range A1:A2.
[image: Function in Excel]
[bookmark: enter-formula]
Enter a Formula

To enter a formula, execute the following steps.
1. Select a cell.
2. To let Excel know that you want to enter a formula, type an equal sign (=).
3. For example, type the formula A1+A2.
[image: Enter a Formula]
Tip: instead of typing A1 and A2, simply select cell A1 and cell A2.
4. Change the value of cell A1 to 3.
[image: Recalculation]
Excel automatically recalculates the value of cell A3. This is one of Excel's most powerful features!
Edit a Formula

When you select a cell, Excel shows the value or formula of the cell in the formula bar.
[image: Formula Bar]
1. To edit a formula, click in the formula bar and change the formula.
[image: Edit a Formula in Excel]
2. Press Enter.
[image: Edited Formula]
[bookmark: operator-precedence]

Operator Precedence
Excel uses a default order in which calculations occur. If a part of the formula is in parentheses, that part will be calculated first. It then performs multiplication or division calculations. Once this is complete, Excel will add and subtract the remainder of your formula. See the example below.
[image: Operator Precedence]
First, Excel performs multiplication (A1 * A2). Next, Excel adds the value of cell A3 to this result.
Another example,
[image: Parentheses]
First, Excel calculates the part in parentheses (A2+A3). Next, it multiplies this result by the value of cell A1.

Copy/Paste a Formula
When you copy a formula, Excel automatically adjusts the cell references for each new cell the formula is copied to. To understand this, execute the following steps.
1. Enter the formula shown below into cell A4.
[image: Copy a Formula Example]
2a. Select cell A4, right click, and then click Copy (or press CTRL + c)...
[image: Click on Copy]
...next, select cell B4, right click, and then click Paste under 'Paste Options:' (or press CTRL + v).
[image: Click on Paste]
2b. You can also drag the formula to cell B4. Select cell A4, click on the lower right corner of cell A4 and drag it across to cell B4. This is much easier and gives the exact same result!
[image: Drag an Excel Formula]

Result. The formula in cell B4 references the values in column B.
[image: Copy a Formula Result]
[bookmark: insert-function]



Insert a Function
Every function has the same structure. For example, SUM(A1:A4). The name of this function is SUM. The part between the brackets (arguments) means we give Excel the range A1:A4 as input. This function adds the values in cells A1, A2, A3 and A4. It's not easy to remember which function and which arguments to use for each task. Fortunately, the Insert Function feature in Excel helps you with this.
To insert a function, execute the following steps.
1. Select a cell.
2. Click the Insert Function button.
[image: Insert a Function]
The 'Insert Function' dialog box appears.
3. Search for a function or select a function from a category. For example, choose COUNTIF from the Statistical category.
[image: Insert Function Dialog Box]
4. Click OK.
The 'Function Arguments' dialog box appears.
5. Click in the Range box and select the range A1:C2.
6. Click in the Criteria box and type >5.
7. Click OK.
[image: Function Arguments Dialog Box]

Result. Excel counts the number of cells that are higher than 5.

[image: COUNTIF Result]

Note: instead of using the Insert Function feature, simply type =COUNTIF(A1:C2,">5"). When you arrive at: =COUNTIF( instead of typing A1:C2, simply select the range A1:C2.





Chapter 3:	Workbook
[bookmark: open-existing-workbook]Workbook is another word for your Excel file. When you start Excel, click Blank workbook to create an Excel workbook from scratch.

Open an Existing Workbook
To open a workbook you've created in the past, execute the following steps.
1. On the File tab, click Open.
2. Recent shows you a list of your recently used workbooks. You can quickly open a workbook from here.
3. Click Browse to open a workbook that is not on the list.
[image: Backstage View in Excel]














Close a Workbook
To close a workbook (and Excel), click the upper right X. If you have multiple workbooks open, clicking the upper right X closes the active workbook.
[image: Close Excel Workbook]
[bookmark: create-new-workbook]
Create a New Workbook
Sometimes you want to start all over again. To create a new workbook, execute the following steps.
1. On the File tab, click New.
2. Click Blank workbook.
[image: Create a New Excel Workbook]
[bookmark: turn-off-start-screen]

















Chapter 4:	Worksheets
This fourth chapter looks at worksheets and demonstrates how to select a worksheet; insert a worksheet; rename a worksheet; move a worksheet; delete a worksheet and copy a worksheet. Finally we will look at how to format cells.
[bookmark: select-worksheet]A worksheet is a collection of cells where you keep and manipulate the data. Each Excel workbook can contain multiple worksheets.
Select a Worksheet
When you open an Excel workbook, Excel automatically selects Sheet1 for you. The name of the worksheet appears on its sheet tab at the bottom of the document window.
[image: Sheet1]

Insert a Worksheet
You can insert as many worksheets as you want. To quickly insert a new worksheet, click the plus sign at the bottom of the document window.
[image: Insert a Worksheet]
[image: Added Sheet]Result: 

[bookmark: rename-worksheet]


Rename a Worksheet
To give a worksheet a more specific name, execute the following steps.
1. Right click on the sheet tab of Sheet1.
2. Choose Rename.
[image: Rename a Worksheet]

3. For example, type Sales 2016.
[image: Specific Name]

Move a Worksheet
To move a worksheet, click on the sheet tab of the worksheet you want to move and drag it into the new position. 
1. For example, click on the sheet tab of Sheet2 and drag it before Sales 2016.
[image: Move a Worksheet]
Result:
[bookmark: delete-worksheet][image: Different Order]
Delete a Worksheet
To delete a worksheet, right click on a sheet tab and choose Delete.
1. For example, delete Sheet2.
[image: Delete a Worksheet]
Result:
[image: One Worksheet left]

Copy a Worksheet
Imagine, you have got the sales for 2016 ready and want to create the exact same sheet for 2017, but with different data. You can recreate the worksheet, but this is time-consuming. It's a lot easier to copy the entire worksheet and only change the numbers.
1. Right click on the sheet tab of Sales 2016.
2. Choose Move or Copy. The 'Move or Copy' dialog box appears.
3. Select (move to end) and check Create a copy.
[image: Copy a Worksheet]
[image: Dialog Box]

4. Click OK.
Result:
[image: Copied Worksheet]
Note: you can even copy a worksheet to another Excel workbook by selecting the specific workbook from the drop-down list (see the dialog box shown earlier).

Format Cells 
When we format cells in Excel, we change the appearance of a number without changing the number itself. We can apply a number format (0.8, £0.80, 80%, etc) or other formatting (alignment, font, border, etc.).
1. Enter the value 0.8 into cell B2.
[image: General Format in Excel]
By default, Excel uses the General format (no specific number format) for numbers. To apply a number format, use the 'Format Cells' dialog box.
2. Select cell B2.
3. Right click, and then click Format Cells (or press CTRL + 1).
[image: Format Cells]
The 'Format Cells' dialog box appears.
4. For example, select Currency. Note: Excel gives you a life preview of how the number will be formatted (under Sample).
[image: Select Currency]











5. Click OK.
[image: Currency Format]
Cell B2 still contains the number 0.8. We only changed the appearance of this number. The most frequently used formatting commands are available on the Home tab.
6. On the Home tab, in the Number group, click the percentage symbol to apply a Percentage format.
[image: Percentage Format]
7. On the Home tab, in the Alignment group, centre the number. 
[image: Center Alignment]
8. On the Home tab, in the Font group, add outside borders and change the font colour to blue.
[image: Borders and Font Color]

Result:
[image: New Format]



Keyboard Shortcuts 
In this section, we will be looking at some timesaving shortcuts, including: Basic; Moving; Selecting; Formulas and Formatting. Please open the spreadsheet marked “Keyboard Shortcuts”
Keyboard shortcuts allow you to do things with your keyboard instead of your mouse to increase your speed.
[bookmark: basic]Basic
Select cell B2.
[image: Basic Example]
1. To select the entire range, press CTRL + a (if you press CTRL + a one more time Excel selects the entire sheet).
[image: CTRL + a]

2. To copy the range, press CTRL + c (to cut a range, press CTRL + x).

3. Select cell A6 and press CTRL + v to paste this range.
[image: CTRL + v]

4. To undo this operation, press CTRL + z
[bookmark: moving]Moving
Select cell B2.
[image: Moving Example]

1. To quickly move to the bottom of the range, hold down CTRL and press ↓
[image: CTRL + down]

2. To quickly move to the right of the range, hold down CTRL and press →
[image: CTRL + right]

Try it yourself. Hold down CTRL and press the arrow keys to move from edge to edge.
[bookmark: selecting]
Selecting
Select cell A1.
[image: Selecting Example]
1. To select cells while moving down, hold down SHIFT and press ↓ a few times.
[image: Shift + down]

2. To select cells while moving to the right, hold down SHIFT and press → a few times.
[image: Shift + right]


Formulas
Select cell F2.
[image: Formulas Example]

1. To quickly insert the SUM function, press ATL + =, and press Enter.
[image: Atl + =]





2. Select cell F2, hold down SHIFT and press ↓ two times.
[image: Shift + down]

3. To fill a formula down, press CTRL + d (down).
[image: CTRL + d]
Note: in a similar way, you can fill a formula right by pressing CTRL + r (right).
[bookmark: formatting]

Formatting
Select the range B2:F4.
[image: Formatting Example]

1. To launch the 'Format cells' dialog box, press CTRL + 1
2. Press TAB and press ↓ two times to select the Currency format.
3. Press TAB and press ↓ two times to set the number of decimal places to 0.
[image: Format Cells dialog box]
4. Press Enter.

Result:
[image: CTRL + 1]
5. To quickly bold a range, select the range and press CTRL + b
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